Filter › Troubleshoot
No Internet Message on Android Devices
Overview
Some customers using Securly SmartPAC or SmartDNS on Android devices have noticed a 'No Internet Connection' notification appearing. This is a cosmetic issue caused by the Android system attempting to connect to google.com to validate its internet connection.
Cause
The issue arises because Securly SmartPAC and SmartDNS inspect all traffic to google.com. The traffic returned to the device is re-encrypted with the Securly SSL certificate, which the Android Operating System does not accept.
This occurs due to a concept known as certificate pinning, where the application or operating system will only accept a preconfigured certificate. Since Securly SmartPAC and SmartDNS perform Man-in-the-Middle (MiTM) inspection on all Google traffic and re-encrypt it with our own certificate, the certificate provided is not accepted, resulting in the message generated by the Android OS.
Solution
No action is required to resolve this message, as it does not affect the device's performance or the effectiveness of the Securly Filter.